Jump to content
RedRam

Code P0720 with weird problem

Recommended Posts

I have been chasing electrical gremlins ever since I converted my auto to a manual, I first had the park/nuetral safety switch wired funny so my cruise wouldn't work but I found some info and rewired it. I went out and rewired it and when I was done took it for a test drive but found that I had another problem so I checked my codes and found a

P0720 (M) Low Output SPD Sensor RPM,

Above 15 MPH

The relationship between the Output Shaft Speed Sensor

and vehicle speed is not within acceptable limits.

P0720 (M) Low Output Spd Sensor RPM Above

15 mph

Output shaft speed is less than 60 rpm with vehicle speed

above 15 mph (4-speed auto. trans. only).

My problem is that when I first start my truck and go it will only rev to 2000rpm until I reach 15mph, then it will run fine even when I go to stop and then start again it will run normal until I shut it off again, then its the same problem. So has anyone had this problem and how did you find a solution or am I just stuck with this? Any help is appreciated, thanks Andrew.

Share this post


Link to post
Share on other sites

Your using the auto trans ECM aren't you?

The output sensor is on the back of the auto transmission, which isn't something on a manual trans.

I'm not sure how to make it think it's working.

All those PITA things is the main reason I haven't tried to swap my auto for a 5/6 speed.

Share this post


Link to post
Share on other sites

I still have both the ECM and PCM that originally came on the truck and with all of the information I gathered I never seen it coming but always expected something else. This is really the only thing that has come up on this conversion that is a PITA.

Share this post


Link to post
Share on other sites

From everything I have ever read about this, you have to change out the ECM when you do this tranny change. I'm surprised your even up and running. I bet if you take the truck in to have it checked for codes it's probably full of em.

Share this post


Link to post
Share on other sites
Guest Mopar1973Man
I still have both the ECM and PCM that originally came on the truck and with all of the information I gathered I never seen it coming but always expected something else. This is really the only thing that has come up on this conversion that is a PITA.

Yeap... This is your problem. The on board PCM computer on the firewall is having a fit. The fact is that computer is still looking for a AUTO trans but the manual is different.

Share this post


Link to post
Share on other sites
Yeap... This is your problem. The on board PCM computer on the firewall is having a fit. The fact is that computer is still looking for a AUTO trans but the manual is different.

Theres got to be a way around this....

Share this post


Link to post
Share on other sites
Guest Mopar1973Man
Theres got to be a way around this....

If it was me I would of took the PCM from the truck I got the transmission from. As long as the donor truck was a like model to yours.

Dealer could probably re-program it, but I'd hate to know what they would charge if they were smart enough to know how to do it.

Well they could... But like you said Dr. Evil only if they know how. These shop guys are basically just book smart... You might get lucky and find a guy that has been playing awhile with the computers. :thumbup:

Share this post


Link to post
Share on other sites

I have talked to some dealerships before and you have to have a VIN from a truck that is the same year with the same options you have since the ECM and PCM talk to each other, but they will not do a reflash, and the reflash is not to expensive. I searched for hours before I did this conversion and never found anything like this, it is mostly how to get the cruise control to work again. I have been up and runnig for about 6 months or so just chasing these problems. So I will see if I can find an ECM and PCM for my truck and see if that fixes the problem. Thanks for the help, Andrew.

Share this post


Link to post
Share on other sites

For those that were at the dinner meeting knoew that my truck was not running right. So I decided to do some testing with the other Pcm that I have, and wouldn't you know it, it runs perfect but there are still some other problems that I will address like the cruise light stays on all of the time but on the other hand I only have 1 fault code and it is 1693. So my next plan of action is to try and get both a Ecm and Pcm for my truck and I think it will fix all of the problems. Also does anybody know of some good salvage yards around here or does anybody have a 2001 5spd with drums that would let me have the part number off of there Ecm and I could get one from around here. Thanks Andrew.

Share this post


Link to post
Share on other sites

Somebody just posted on here a few months back about a salvage yard in your area there that had several of these trucks available. Might just look through some posts here or somebody else may remember it. I'll try to do a search for it.

Share this post


Link to post
Share on other sites

Good to hear that you are on the right track with that problem. I would try calling Holst truck parts in IF, phone # 522-1788. I am guessing that they will be your best bet.

Share this post


Link to post
Share on other sites

Thanks for the info, I just had a gentlemen on TDR that said his salvage yard does computer interchages, so I will see if he will take the spare ones that I have for the ones that I need and if so everything should be great. I will also check on here for the other salvage yard but I might have checked with them already. Also I will check with Holst tomorrow if they are open and see what they have to say. Once again thanks, Andrew.

Share this post


Link to post
Share on other sites

I believe that Holst was the one brought up before. I know they have a ton of used and new parts there. They normally have some competitive pricing. I don't think they are open tomorrow, but it won't hurt to call. Sounds like that other place you found might be a good option to pursue as well. Keep us posted on what you find.

Max

Share this post


Link to post
Share on other sites

Who ever it was gave a phone number and said they weren't on the net anywhere. I tried a search and came up empty handed. I'm hopin somebody jumps in here that remembers.

Share this post


Link to post
Share on other sites
Guest 9812VCTD

Andrew,

Glad things are starting to improve with your truck, sounds like your on the right track!:thumbup: I second calling Holst I've done business with them many times, great people and great pricing!

Justin

Share this post


Link to post
Share on other sites

Ok did you get your truck fixed RedRam? I just finished converting my 01.5 Yesterday and I'm having the same problem. I had never heard of this happening until I did mine. Oh and if anyone has a pcm pm me please. My truck is a 01.5 2wd. Thanks 99 Cummins for pointing me to this thread.

Andy

Share this post


Link to post
Share on other sites

No I have not got my truck fixed yet but I am almost positive that I have found a solution to the problem. I have found that the auto PCM is having a fit not getting any info from the tranny, so I had a spare PCM that is from a 2002 with a 6-spd, I put that on and everything works except the cruise control. I believe that the reason that the cruise control is not working is 1. I have two different computers in the truck and 2. I think that the ECM on a manual controls the cruise and not the PCM with an auto. So to fix the problem I feel that replacing both the ECM and PCM with one from a manual that fits your trucks details, such as year, (wheather it is an 2001 or a 2001.5 it makes a difference) trans, emission, etc. I have done some research online and found a place in No. Carolina (I think) that has the best prices on a set of computers, here is the info I found, S&T Enterprise phone number is 704-210-8636 or 704-210-8153. They are open from 9am-7pm Eastern time and ask for Shane, he quoted me $620 with shipping and a 90 day warranty with them. You may want to also do a search and see if you can come up with anything there may bo a better deal out there. Hope this helps and if you have any other question feel free to ask, Andrew.

Share this post


Link to post
Share on other sites

I will let you know if that fixes it since I am planning on getting them here in the next two weeks after I get payed. I would send mine out but I figure since I have two complete sets of computers I could sell them and make a little on them. Also let me know if you get your up and running with the reprogram. Andrew.

Share this post


Link to post
Share on other sites

Well I did some more digging and talked to Marco and he told me even with the ECM reprogramed I will still need a PCM for it. If that works for you let me know and let me know were you got your PCM from and a cost. Marco told me he can reprogram the ECM with a Smarty so since I want one it gives me a reason to buy one. Let me know how it turns out for you. You and me are the only two apparently that have had this problem.

Andy

Share this post


Link to post
Share on other sites

OK I got mine fixed it looks like. I grounded out the neutral saftey wire instead of hooking it up to the switch on the clutch and fooled the computer into thinking that the truck is in neutal or Park keeping it from defueling at 2000RPMs on take off. I did however loose my cruise control that I only use once a year. I'm going to put a toggle switch in to see if I can make it work once I get up to speed and get going. If it works great if not well I'm only out a few bucks for a switch.

Andy

Share this post


Link to post
Share on other sites

I tried mine at 65MPH and it didnt work so I'm thinking that with the Nuetral safety grounded it is locking out cruise. What I want to do is try a switch in that wire and see if I can break the circuit to get cruise working again. I'm afraid it will default back to not fueling over 2000RPMS though but we will see later this week.

Andy

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



  • Upcoming Events

    No upcoming events found
  • Recently Browsing

    No registered users viewing this page.

×