Jump to content
Sign in to follow this  
Uncle Bubba

Windsheild Wiper Problems

Recommended Posts

Just thawed out from the ice storm we had around here today and now my wipers are haywire. They don't work at all on intermitent and seem pretty draggy on low. When you turn the switch off, they stop wherever they are at instead of returning to the bottom.

Share this post


Link to post
Share on other sites

might be time for an new lever switch do you have any ice build up down by the wiper motor might see if you have any bad grounds just some things to think about

Share this post


Link to post
Share on other sites
Guest Mopar1973Man
Just thawed out from the ice storm we had around here today and now my wipers are haywire. They don't work at all on intermitent and seem pretty draggy on low. When you turn the switch off, they stop wherever they are at instead of returning to the bottom.

From my experience with my 1973 Charger... The return problem is a reed switch in the wiper motor. As for the draggy motort action... You might of wore out the brushes in it or burnt a winding...

But this is 1973 knowledge here... :roll:

Share this post


Link to post
Share on other sites

Sounds like the wiper motor is dying. When I bought my truck it was doing the same thing. New wiper motor and all is well. About $75 from Napa.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  



  • Upcoming Events

    No upcoming events found
  • Recently Browsing

    No registered users viewing this page.

×