Jump to content


  • Upcoming Events

  • Recently Browsing

    No registered users viewing this page.

butch7.3

service light keeps showin up

Recommended Posts

I have a 2000 powerstroke i have a edge chip and when i turn it up me service engine light comes on. I herd there was a part to fool it but dont know what that part is ? I also need to get a torque converter what should i look for when buyin one thanks fof all your help

Share this post


Link to post
Share on other sites
Guest POWERTRIP

What code are you setting? When does it come on? After a hard run or just normal driving? Could be a 1211 which is common when you run in higher tunes, or could be an overboost code also

As for a converter, triple disk, billet front cover. Alot have used a new Ford converters, they offer a reg duty and a heavy duty triple disk with billet front. Just really depends on how much you wanna spend and the condition of your tranny . BTS, John Wood, DI, I know there are others, these are just a few that can get you a good converter.

Share this post


Link to post
Share on other sites

One of the benifits of ITP's overboost annihilator is that it allows your pcm to only see 22lbs of boost and by doing that you will not get put into defueling mode. If you been experiencing the ses light you are gouing to love the OA. Takes about 5 minutes to install.

Share this post


Link to post
Share on other sites

If the Edge chip you're using is the Juice with Attitude, once you put in the overboost kit, the Attitude monitor will no longer show you any boost over 22psi. As it reads boost from the map sensor, and the overboost kit will be restricting what the map actually sees.

So the truck will still be making say 25-26psi, but your monitor won't show that.

Share this post


Link to post
Share on other sites

Yes. Overboost kit, boost fooler, same thing. All it does is keep the map sensor from seeing more than 22psi of boost, which keeps the pcm of setting that engine light and defueling the motor.

I run ITP Diesels Overboost Annihilator on both of my trucks. 45psi boost and no engine light :rockin:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×