Jump to content
EVIL OVAL

Had to bite the bullet

Recommended Posts

It was leaking oil like a siv, and there was a lot of oil in my intake tube as well, I would have liked to have gone with a aftermarket one but i needed it put back together as its my daily driver, and ford had one on the shelf. It had 185,000 miles on it.

Share this post


Link to post
Share on other sites

^^^ What Steve said ^^^. Who told you your turbo was fried? Did ya lose your boost, check the shaft for play ( ya I said shaft Randy ). Did ya have to give up your old turbo for a core if not I would like to see it.

Share this post


Link to post
Share on other sites

yeah the shaft did have quite a bit of play...how much oil is the intake tube supposed to have because there was alot...i mean alot, and there was a puddle of oil in my valley under it too. The guy that helped me is our diesel mechanic where i work at. Oh yeah i did have to give the turbo as a core.

Share this post


Link to post
Share on other sites

Radial play on the shaft is fine as long as it does not hit the housing. End play on the shaft is bad. I bet your turbo was fine.....

Colder temps are going to bring more blow by, PSD have alot of blowby and it is normal.

Share this post


Link to post
Share on other sites

Ordered my new upgraded Turbo on Sunday......my truck only has 69,000 miles on it and I don't dog it.....change oil every 3,000.....all regular interval maintenance complied with.......

I was headed up Elk hunting and noticed the Turbo whining a bit louder than, what I thought, was normal. Pulled over to check the ATV trailer when we hit the dirt road going into the mountains.....it looked like I was fogging for mosquitoes.......white/blueish smoke puking out of tailpipe...... My hunting partner called his diesel mechanic/powerstroke specialist and he said he suspected Turbo bearings/seals......Turned around and went back to town....Had "RED" towed to my dealer for a diagnostic.....sure nuff.....Turbo bearings and seals wasted......Dealer wanted $1700 to fix....BS!......Ordered the upgraded Turbo from Ron's in Salt Lake City....should have it today......When I pulled it apart, the Turbo was toast.....bearings and seals shot and excessive oil in exhaust. Impeller tips on exhaust side broken off....Not good.....Glad it was on the exhaust side, not intake....A new motor is alot more than just the Turbo.....Also had alot of oil puking out wastegate actuator shaft hole.....There was alot of oil on top of the motor and dripping down the back of the motor onto my garage floor.....Gonna do the EBPS maintenance while I've got it all apart......Turbo cost $820.....alot better than $1700.......

Share this post


Link to post
Share on other sites

The one I ordered has the Banks impeller and better bearings. Supposed to move alot more air with faster spooling and more power. I guess we'll see.....I'll post an update after I get it installed and RED is back on the road......

Share this post


Link to post
Share on other sites
Guest ShanesLB7
The one I ordered has the Banks impeller and better bearings. Supposed to move alot more air with faster spooling and more power. I guess we'll see.....I'll post an update after I get it installed and RED is back on the road......

Keep us posted... Atleast with the banks im peller it won't smoke!!!!:slap: LOL

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




  • Upcoming Events

    No upcoming events found
  • Recently Browsing

    No registered users viewing this page.

×