Jump to content


  • Upcoming Events

    No upcoming events found
  • Recently Browsing

    No registered users viewing this page.

xyz123

What now?

Recommended Posts

I am not sure what section this fits in but I hope some knowledgable people read it. I was hauling a load home from Utah and my tranny got hot it was reading about 280 when I got puled over. as soon as I stopped it continued to climb and pegged at 320 degrees. It is in my Suburban and is a 47RE with an RH valve body and overdrive section. After it cooled down a bit I started driving and it started slipping. Then I lost all gears. Nothing! What is the damage, and how do I fix it so it never breaks again? Where do I piost about a franknstein Cummins Suburban? DId I also mention money is tight! Thanks in advance.

Share this post


Link to post
Share on other sites
Guest ShanesLB7
I am not sure what section this fits in but I hope some knowledgable people read it. I was hauling a load home from Utah and my tranny got hot it was reading about 280 when I got puled over. as soon as I stopped it continued to climb and pegged at 320 degrees. It is in my Suburban and is a 47RE with an RH valve body and overdrive section. After it cooled down a bit I started driving and it started slipping. Then I lost all gears. Nothing! What is the damage, and how do I fix it so it never breaks again? Where do I piost about a franknstein Cummins Suburban? DId I also mention money is tight! Thanks in advance.

sound like you melted the valve body.. When towing heavy and if you need to pull over to cool it off DONT put it in park... that stops the fluid from circulating and it superheats it... Which you know by now.. Next time Put the parking break on park on as level ground as possible and leave it in Neutral... That lets the fluid circulate and cools down quicker...

Sorry to hear about your tranny

Share this post


Link to post
Share on other sites

I would post it up in the 12v section maybe one of the mods can move this for you. Well i would say that your trans is gone and its time for a rebuild. I would Pm Lumpdog on here he is the trans guy. It may take him till next week to respond because they are headed to moab. but he is the cheapest that i have found.

Share this post


Link to post
Share on other sites

Yup, chatted with John on the way to Moab, sounds like he baked it good. He only has a remote mounted trans cooler on this as well, located near the rear axle, so lack of cooling with a big load is no good.

It is time to pull it, open it up, and see what's been damaged.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×