Jump to content


  • Upcoming Events

    No upcoming events found
  • Recently Browsing

    No registered users viewing this page.

Recommended Posts

Well today after Jay set the timing to 15 for me this morning:thumbup: ( sorry you frost you butt off) I decided to install my fuel plate and governor springs. The retainers were about to fall off the springs they were on the last click before they would have backed off. I measured and re-measured but they were no where near .060 I installed the new springs and set them to .060 which was 5 clicks on mine. ANYWAY has anyone had their retainers this loose???

Share this post


Link to post
Share on other sites
Guest 9812VCTD

Glad to hear you got some more work done to your truck. I just had Jay set my timing he does an awesome job. What plate did you end up using? That is wierd about your springs, amazing it still ran good with them that loose. I've got to take some time and tighten mine I'm not getting the RPM I need. How high can you rev your truck?

Justin

Share this post


Link to post
Share on other sites

Well I might have ran like crap before I dont know I took a big gamble on buying a motor that I didn't get to see it run. I can't really spin her up yet since I have to put the front clip and stuff still on. I so far have only started it and let it idle for a little then up to 2000 or so and shut her down since I don't have any water in it yet. I put a #10 in where the stock plate was I might have to back it off a little since it is almost all the way forward. I can't wait to drive this truck:coal

Share this post


Link to post
Share on other sites
Guest 9812VCTD

X2 get that thing on the road...8-) You got any pics of it you can post up?

Justin

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×