Jump to content


  • Upcoming Events

    No upcoming events found
  • Recently Browsing

    No registered users viewing this page.

Dave

dead pedal

Recommended Posts

I have started experiancing dead pedal with my 01 just a couple times. since this is the second pump on this on this truck Im wondering if its worth the extra expence to p pump it. does anyone have one, and is it worth it on a work truck? Im planning on keeping the truck untill its ready for the scrapyard I dont want a lot of extra power just a dependable truck that will go for 5 or 6 more years.

Share this post


Link to post
Share on other sites

I just went with the next best thing, a belt driven mechanical pump and so far it's doin great. With the P pump you lose your adjustability to control smoke and heat. With this pump it is completely mechanical but you keep the advantages of the 24V. The more RPM's your turnin the more PSI it pushes. Mine is set to idle at 12psi and reach 16 at full throttle. This is also completely adjustable with a bypass regulator set to wherever you want it.

You can also run it with an electric pump set to come on automatically with a pressure switch anytime you fall under a certain psi. This mostly just acts as a primer pump since the belt drive only pumps when the engine is turning. From the time I start the truck it takes about 4 seconds to reach full pressure, so thats how long the electric pump would run each time you start the truck.

Share this post


Link to post
Share on other sites
I have started experiancing dead pedal with my 01 just a couple times. since this is the second pump on this on this truck Im wondering if its worth the extra expence to p pump it. does anyone have one, and is it worth it on a work truck? Im planning on keeping the truck untill its ready for the scrapyard I dont want a lot of extra power just a dependable truck that will go for 5 or 6 more years.

In my case I fixxed my dead pedal by recalibrating the APPS. I tried just resetting it with the accelerator pedal and that didn't help any. So I pulled he sensor to get the ohm reading and re-set it to match. This fixxed the intermintent dead pedal, Higher then normal EGT's and gave me a good increase in power.

It's pretty unlikely that a lift or injection pump is causing a dead pedal. Just an opinion.

Share this post


Link to post
Share on other sites
dennis that sounds like a purty sweet setup

Thanks Dustin. The pucker factor always set's in a little when your tryin somethin different from what everybody else has but so far everything is rollin along smooth with this pump.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×