Jump to content


  • Upcoming Events

    No upcoming events found
  • Recently Browsing

    No registered users viewing this page.

Recommended Posts

Here we are again !! We towed our trailer (only 7,000 lbs) back to Nampa from Burley and we are still having fuel millage trouble ??????? On the way we got about 7 1/2 at 70 mph . We could not pull any of the bigger hills around Glenn's Ferry any faster than 65 mph ???????? We could pull the hills at 70 mph to 75 with are 6.0 Gas Chevy ( w/ the trailer) and we feel like the power is just not there ! What can we do about the fuel millage and power ??? PLEASE HELP !!! Give us some tips this is our first Diesel and do not quite know what to expect......... What is the normal ? Once again we want to thank you all for the help you have already given us ! Hope to hear from you soon !!:thumbup:

Share this post


Link to post
Share on other sites

sell it and get a cummins lol j/k

i am no d-max knowit all but could it be a fuel pressure problem did it through any codes but that realy sucks for just towing a 7k trailer idahorob could maybe help ya with some more power

Share this post


Link to post
Share on other sites

Very FUNNY :lol: LOL !!!!

No way we love our truck !!! We just need to figure out why its not acting like a D max should !!! As far as we know it has not thrown any codes .... I guess I could go out and call OnStar and ask ...... Dose your Cummins do that LOL:twisted: :thumbup: Just kidding ... I know it does'nt ..... But it will pull a hill HUH !!

Share this post


Link to post
Share on other sites

WE ARE VERY TICKED !!!!!! IT SUCKS !!!! Sorry I had to mess with you !!! You know no one is safe from the Dodge Chevy Ford War ever !!!! Thanks for your advice ........ Do you have a stick a TNT maybe I can make a flower pot out of it !! I guess I could still say I own a Dmax:smart: Lol I just want it fixed !!!!

Share this post


Link to post
Share on other sites

What year is the truck? If it is a late 04 or 05 it is possible the fan is running too much and causing a loss of power and fuel mileage. If you're around Boise much I would see if you can get in touch with IdahoRob and see if he can do some datalogging with EFILive to see if there are any indications of a problem. Sorry you're having trouble. I hope you get it figured out.

Share this post


Link to post
Share on other sites

I'm not much of a tech guy I just kind if throw out the obvious whether it's relevant or not, but maybe they have the crapy injectors? GM will replace those for free as long as you're under 200,000 (i think).

On the way back from Utah pulling a horse trailer I was goin 90 up hills and passin pretty much every one. The trailer was empty. I wouldn't do that to my horsey

Share this post


Link to post
Share on other sites
I'm not much of a tech guy I just kind if throw out the obvious whether it's relevant or not, but maybe they have the crapy injectors? GM will replace those for free as long as you're under 200,000 (i think).

On the way back from Utah pulling a horse trailer I was goin 90 up hills and passin pretty much every one. The trailer was empty. I wouldn't do that to my horsey

Injector 200k warranty.....LB7 only

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×